VIP Enterprise Gateway Validation Server error "port already in use" when starting service
search cancel

VIP Enterprise Gateway Validation Server error "port already in use" when starting service

book

Article ID: 376456

calendar_today

Updated On:

Products

VIP Service

Issue/Introduction

Error "port already in use" when attempting to start the RADIUS Validation Server.

Cause

Port is already in use due to remnant VIP Services after and upgrade that need to be manually removed 

Resolution

Method 1

  1. Change the listening port number within Radius configuration page of EGConsole to a new port number (i.e., change 1812 to 1813), then start service
  2. If service starts, then edit the port number again to return it to the original value and restart service again

 

Method 2

If Method 1 does not work, then follow these steps to kill the existing service

Windows:

  • From the Windows Services console, located the Symantec VIP Validation Server service name. 
  • Open an Administrator command prompt and navigate to bin folder in the existing Enterprise Gateway location (example: C:\Program Files (x86)\Symantec\VIP_Enterprise_Gateway\Validation\bin\
  • Run this command: vsauthremoveserver.exe -servicename Cisco_ASA

Linux:

  • Use the netstat command to determine what PID is using that port (replace 1812 with the correct port)
    • [root@RHEL ~] # sudo netstat -anp | grep 1812
  • Use the PS command to verify the PID. There may be 2 services associated with the Validation Server. 
  • Use the kill command to remove the services.