office365 does not connect to the Microsoft service after configuring proxy
search cancel

office365 does not connect to the Microsoft service after configuring proxy

book

Article ID: 376373

calendar_today

Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

After configuring proxy settings in the office 365 probe, it cannot connect to the Microsoft office service. The following log entry is seen in the probe's log:

*** HttpRequestRetryHandler >>> Reason >>> PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target, executionCount : 5

Environment

DX UIM 20.4.x 

Office 365 1.03 or newer 

 

Cause

The company's proxy uses an internal self signed SSL certificate 

Resolution

The Office 365 probe could not recognize the SSL certificate presented by the proxy as it was self-signed - if such a certificate is in use, you must upload the root certificate to the robot's JRE cacert keystore file, so the probe is able to validate the self-signed certificate presented by the proxy server.