Error "Test was not successful: Email test error" while configuring standard email plugin in Aria Operations.
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Error "Test was not successful: Email test error" while configuring standard email plugin in Aria Operations.

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Article ID: 376351

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

  • While validating the connection of the standard email plugin, you might encounter an error indicating that the test connection is unsuccessful: "Test was not successful: Email test error: [Could not connect to SMTP host: <SMTP_Server/IP>, port: 25]"

  • After testing the connection with the Standard Email Plugin, you might observe the following errors in /storage/vcops/log/analytics-UUID.log:
    2024-07-12T04:25:10,879+0000 ERROR [itask-thread-certificate-monitor-thread]  com.integrien.alive.common.util.SSLHandshakeHandler.makeSSLHandshake - Cannot get ssl certificate chain due to exception: Unsupported or unrecognized SSL message
    javax.net.ssl.SSLException: Unsupported or unrecognized SSL message
            at sun.security.ssl.SSLSocketInputRecord.handleUnknownRecord(Unknown Source) ~[?:?]
            at sun.security.ssl.SSLSocketInputRecord.decode(Unknown Source) ~[?:?]
            at sun.security.ssl.SSLTransport.decode(Unknown Source) ~[?:?]
            at sun.security.ssl.SSLSocketImpl.decode(Unknown Source) ~[?:?]
            at sun.security.ssl.SSLSocketImpl.readHandshakeRecord(Unknown Source) ~[?:?]
            at sun.security.ssl.SSLSocketImpl.startHandshake(Unknown Source) ~[?:?]
            at sun.security.ssl.SSLSocketImpl.startHandshake(Unknown Source) ~[?:?]
            at com.integrien.alive.common.util.SSLHandshakeHandler.makeSSLHandshake(SSLHandshakeHandler.java:156) ~[alive_platform.jar:?]
            at com.integrien.alive.common.util.SSLHandshakeHandler.makeSSLHandshake(SSLHandshakeHandler.java:126) ~[alive_platform.jar:?]
            at com.integrien.analytics.certificate_monitoring.OutboundPluginMonitoredResource.monitorAndAddToResult(OutboundPluginMonitoredResource.java:200) ~[vcops-analytics-1.0-SNAPSHOT.jar:?]
            at com.integrien.analytics.certificate_monitoring.OutboundPluginMonitoredResource.testMonitorEmailPlugin(OutboundPluginMonitoredResource.java:122) ~[vcops-analytics-1.0-SNAPSHOT.jar:?]
            at com.integrien.analytics.certificate_monitoring.OutboundPluginMonitoredResource.testMonitorCertificateExpiration(OutboundPluginMonitoredResource.java:137) ~[vcops-analytics-1.0-SNAPSHOT.jar:?]
            at com.integrien.analytics.CertificateMonitorTask.run(CertificateMonitorTask.java:311) ~[vcops-analytics-1.0-SNAPSHOT.jar:?]
            at com.vmware.vcops.platform.common.taskexecutor.IScheduledTask.runInternal(IScheduledTask.java:61) ~[alive_platform.jar:?]
            at com.vmware.vcops.platform.common.taskexecutor.ScheduledTaskExecutor.lambda$executeTask$2(ScheduledTaskExecutor.java:129) ~[alive_platform.jar:?]
            at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source) ~[?:?]
            at java.util.concurrent.FutureTask.run(Unknown Source) ~[?:?]
            at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source) ~[?:?]
            at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source) ~[?:?]
            at java.lang.Thread.run(Unknown Source) ~[?:?]
    2024-07-12T04:25:10,880+0000 ERROR [itask-thread-certificate-monitor-thread]  com.integrien.analytics.certificate_monitoring.AdapterMonitoredResource.monitorAndAddToResult - ssl handshake with endpoint caused the error: Vlog realise
    2024-07-12T04:25:10,880+0000 INFORMATION [itask-thread-certificate-monitor-thread]  com.integrien.alive.common.util.SSLHandshakeHandler.makeSSLHandshake - request for ssl handshake, urls: [https://xxxxx.xxx.xx:3268]
    2024-07-12T04:25:10,884+0000 ERROR [itask-thread-certificate-monitor-thread]  com.integrien.alive.common.util.SSLHandshakeHandler.makeSSLHandshake - Cannot get ssl certificate chain due to exception: Connection reset
    java.net.SocketException: Connection reset
    

Environment

VMware Aria Operations 8.x

Cause

This error typically occurs when the SMTP server is not configured correctly to handle SSL or TLS secure connections.

Resolution

The issue can be resolved by properly configuring the SMTP server to support SSL/TLS encryption.

If the customer is attempting to use SMTPS (SSL SMTP), they should use port 587 instead of port 25.

Customers are advised to collaborate with their internal network and SMTP server teams to configure the SMTP server for SSL/TLS connections.