New NSX segments do not show up in the vCenter network inventory
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Article ID: 376339
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Updated On:
Products
VMware NSX
Issue/Introduction
- Some network segment exists in NSX Manager but not in the vCenter networking inventory.
- Newly formed NSX segments are also not displaying in vCenter inventory.
Cause
- Verify Compute Manager status. Due to the NSX manager's inability to contact DNS, the FQDN of the VCenter server cannot be resolved:

- In case you are getting above error, connect to the NSX manager using root and ping the FQDN and IP address of vCenter server
- If vCenter FQDN does not resolve, try pinging the active DNS server configured on NSX.
- Name servers can be obtain using
cat /etc/resolv.conf
command:
root@nsx-mngr-01:~# cat /etc/resolv.conf
nameserver <ip-address>
- If Name server cannot be reached, update the nameserver settings in NSX Manager.
Resolution
Connect the NSX Manager with admin credentials and update the name server to one that is reachable from NSX Manager:
nsx-mngr-01> get name-servers
Tue Sep 03 2024 UTC 21:49:28.534
<ip-address>
nsx-mngr-01> set name-servers <ip-address>
nsx-mngr-01> get name-servers
Tue Sep 03 2024 UTC 22:08:34.578
<ip-address1>
<ip-address2>
nsx-mngr-01> del name-server <ip-address>
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