New NSX segments do not show up in the vCenter network inventory
book
Article ID: 376339
calendar_today
Updated On:
Products
VMware NSX
Issue/Introduction
- The network segment exists in NSX but not in the vCenter networking inventory.
- Newly formed NSX segments are also not displaying in vCenter inventory.
Cause
- Due to the NSX manager's inability to contact DNS, the FQDN of the VCenter server cannot be resolved.
- Verify compute manager status
- In case you are getting above error, connect to the NSX manager using root
- Ping the FQDN and IP address of vCenter server
- If VCenter fqdn does not resolve, try pinging the active DNS server configured on NSX.
- name servers can be obtain using cat /etc/resolv.conf command
root@nsx-mngr-01:~# cat /etc/resolv.conf
nameserver <ip-address>
- Ping the current nameserver.
- If nameserver cannot be reached, update the nameserver settings in NSX management.
Resolution
Connect the NSX manager with admin credentials.
nsx-mngr-01> get name-servers
Tue Sep 03 2024 UTC 21:49:28.534
<ip-address>
nsx-mngr-01> set name-servers <ip-address>
nsx-mngr-01> get name-servers
Tue Sep 03 2024 UTC 22:08:34.578
<ip-address1>
<ip-address2>
nsx-mngr-01> del name-server <ip-address>
Feedback
thumb_up
Yes
thumb_down
No