Jaspersoft 9.0 integration with CA SDM 17.4 failed
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Jaspersoft 9.0 integration with CA SDM 17.4 failed

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Article ID: 376323

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Updated On:

Products

CA Service Management - Service Desk Manager

Issue/Introduction

ERROR [DeployThread: Copying Custom Files To JasperReport Server] [JasperServerCopyFilesTask] JasperReport Service didnot start after 3mins, DEBUG [DeployThread: Copying Custom Files To JasperReport Server] [CommonProcessUtilities] The Apache Tomcat 8.5 jasperreportsTomcat service is not started.

The older version of Apache Tomcat 8.5 is also hosted on the same Server that is being leveraged for Tomcat 9.0

 

Environment

Release: 17.4.+

Components: JasperSoft 9.0

Cause

Apache Tomcat 8.5 was on the sever because the environment was upgraded from 7.9 to 8.1.1 and the to 9.0.

Resolution

To remove Tomcat version 8.5 one can navigate to <installation drive>:\Program Files\Apache Software Foundation\Tomcat 8.5\Uninstall.exe" /S -ServiceName="Tomcat8" there by uninstalling and removing Tomcat 8.5 services and then reconfigure JasperSoft 9.0  for the Tomcat 9 service. The integration can be executed as expected.

Additional Information

Simply stopping/disabling Apache Tomcat 8.5 services does not resolve the issue of configuring JasperSoft 9.0 for Tomcat 9.