VECO - Cannot save configuration changes - Branch to Hub Site Enabled in cloud VPN but no Hubs assigned
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VECO - Cannot save configuration changes - Branch to Hub Site Enabled in cloud VPN but no Hubs assigned

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Article ID: 376316

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Updated On:

Products

VMware SD-WAN by VeloCloud VMware VeloCloud SD-WAN

Issue/Introduction

You attempt to save configuration changes on the edge Device tab and obtain the following error message with no further explanation. The changes do not successfully save. 

Error message in Text format: "Cannot save changes. There is one or more errors within your configuration."

Environment

SD-WAN / VECO / Edge configuration screen. 

Cause

This behavior is due to having "Branch to Hub Site (Permanent VPN)" enabled within the Cloud VPN module of the edge's assigned profile with no hubs assigned within "Hub Designation" section of the module. You will need to check the global segment as well as other segments to verify this behavior. 

(Below snapshot is captured only for Global segment)

 

Resolution

You can choose one of the following actions based on user preference and network requirements:

  1. Disable "Branch to Hub Site (Permanent VPN)"
    Within the Cloud VPN module of the edge's assigned profile, disable this option if it is enabled and there are no hubs assigned in the "Hubs Designation" section.

  2. Add a Hub Site
    In the Cloud VPN module of the edge's assigned profile, add a hub site to the "Hubs Designation" section if the list is currently empty.

Either of these actions will resolve the VCO UI validation error.

Additional Information

This is not a defect, more recent VECO builds added further reinforcement against invalid configuration which was less strict in older VECO builds. This change will not cause service restart on the edge.