Unable to select a custom policy when creating a schedule for a bill through Automation Central
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Unable to select a custom policy when creating a schedule for a bill through Automation Central

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Article ID: 376203

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

  • When trying to create a schedule for a bill on Chargeback on Aria Operations through Automation Central, you are unable to select a custom policy 
  • The selected policy says 'Historical Policies'. 

Cause

  • This behaviour is by current design. From Automation Central, we are calculating the billing based on the already calculated historical pricing values. So it is not possible to detect exact policy at that point. That is why we show "Historical Policies".
  • In general, if the user is trying to generate a bill by the specific policy, then they can use Chargeback -> Bills -> Generate Bill by selecting a policy from the advanced settings. In this case, they will have a calculation based on that policy for the whole period.
  • As the historical policies are the assigned ones, the calculation happens based on the assigned policy every day.
  • But it will still show "Historical Policies" in the columns of the grid. Historical means it is calculated based on metric values which are generated based on effective policy each day.

Resolution

  • This is expected behaviour. The "Historical Policies" is the Default Policy.
  • To generate a bill for a specific policy, you can use Chargeback -> Bills -> Generate Bill by selecting a policy from the advanced settings.