Appliance VM power-on fails with error "The systemId does not match the current system or the deviceId, and the vendorId does not match the device currently at ###:#.#.""
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Appliance VM power-on fails with error "The systemId does not match the current system or the deviceId, and the vendorId does not match the device currently at ###:#.#.""

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Article ID: 376192

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Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

Few vendor appliance VM power-on operation fails and the user receives the following error message.

message = "The systemId does not match the current system or the deviceId, and the vendorId does not match the device currently at ###:#.#."

Environment

VMware vSphere ESXi 7.x

Cause

  • Some appliance VMs with PCI passthrough devices look for systemID to boot as they are bound to specific host and fail to power on when the ESXi systemID does not match with the systemID associated with VMX (VM configuration).

  • This systemID mismatch issue could occur due to a certificate change, ESXi reinstallation, or any other reason.

Resolution

  • Take note of the appliance VM's systemID entry by checking its VMX file. Search for "systemID".

  • Check the correct systemID using the command "esxcfg-info -a." Search for "System UUID.".

  • If the systemID in the VMX file differs from the "System UUID" in the "esxcfg-info -a" command, update the VMX file with the correct systemID.

  • After changing the systemID, reload the virtual machine (VM) to ensure a successful power-on.
  •