Upgrade fails if Users are configured with special characters in their name.
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Upgrade fails if Users are configured with special characters in their name.

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Article ID: 376161

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Updated On:

Products

VMware Avi Load Balancer

Issue/Introduction

Upgrade fails if Users(Remote and Local) are configured with special characters in their name.

Cause

The special character "@" symbol in the name was causing the issue. 

Resolution

In 30.x versions, The User model had changed which resulted in name field of User to be url encoded which was unexpected by import workflow.

Please verify the logs in Previous partition which will show this error:

1.Get the current partition:

cat /proc/cmdline
BOOT_IMAGE=/vmlinuz root=UUID=a4d1e56b-1c5a-4f22-baab-5ff928dc1831 subroot=/root1 net.ifnames=0 biosdevname=0

This means root1 is current partition.

2. vi /host/root2/var/lib/avi/log/remote_task_manager.INFO

Exception: Import configuration failed importing User with the following errors: [('test.user%40incloud.com', 'user-6e44964a-67bb-4c26-96da-6eab1974abc0', 'Serializing error {\'name\': [\'Enter a valid name.\']} for UserSerializer with data:

 

Workaround:

Delete the user before upgrade or edit the username/name not to contain the @ symbol. After upgrade is completed, please recreate the user.

 

Fix Versions:

30.1.2-2p1

30.2.1