Workbench and Administrator Tool won't start after upgrade
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Workbench and Administrator Tool won't start after upgrade

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Article ID: 376157

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Updated On:

Products

CA Harvest Software Change Manager CA Harvest Software Change Manager - OpenMake Meister

Issue/Introduction

In our VDI environment, after upgrading to Harvest v14.5, when I opened up Workbench this happens

An error has occurred.  See the log file C:\Users\<userid>\com.ca.harvest.workbench.workbenchProduct_14.5.0.45_1642815206_win32_win32_x86_64\configuration\1720727594936.log

 
I get this when I open Administrator

An error has occurred.  See the log file C:\Users\<userid>\.cascm\workspaceAdmn\.metadata\.log


The error message in the .log file is:

java.lang.UnsatisfiedLinkError: Could not load SWT library. Reasons:    C:\Users\DDH0061\.eclipse\com.ca.harvest.workbench.workbenchProduct_14.5.0.45_1642815206_win32_win32_x86_64\configuration\org.eclipse.osgi\160\0\.cp\swt-win32-4948r9.dll: Access is denied

 

Environment

Harvest Software Change Manager all versions

Cause

Security software requiring digital signatures on communications between applications had been implemented in the environment.

Resolution

An exception was made in the digital signing application for the executable path of Workbench and Administrator Tool which resolved the problem. It was placed into the global policy so will be permanent.