Incident severity does not change as expected when using the API
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Incident severity does not change as expected when using the API

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Article ID: 376097

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Updated On:

Products

Data Loss Prevention Network Monitor and Prevent for Email

Issue/Introduction

The API is being used in a script to change the severity of an incident from high to low. When viewing the incident after the the call the incident retains the old value of high.

Environment

16.x

Cause

This can occur when the API is called several times sequentially without delay.

Resolution

Add a couple second delay between the API calls. In this scenario the severity change was being called and then the incident was resolved. Adding the delay addressed the issue.