Troubleshooting Release of System-Allocated IPs via API in Aria Automation 8.x
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Troubleshooting Release of System-Allocated IPs via API in Aria Automation 8.x

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Article ID: 376071

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

Customers may face difficulties when attempting to release system-allocated IP addresses using APIs in Aria Automation 8.x. The issue occurs when the IPs appear to be allocated by the system, even though they are not connected to any resource. 

The response will result in:

{

"message": "Ip addresses are not managed by the user, ids: [########-####-####-####-############] ips:[##.##.##.##]",

"statusCode": 400,

"errorCode": 0,

"serverErrorId": "########-####-####-####-############",

"documentKind": "com:vmware:xenon:common:ServiceErrorResponse"

}

Environment

VMware Aria Automation 8.x

Cause

The inability to release system-allocated IPs via API is by design. These IPs were assigned during provisioning and cannot be managed through public APIs. The API response indicates that the IPs are not user-managed and cannot be released through standard methods. This often happens when IPs allocated via VMware Aria Automation (vRA) are reconfigured or reassigned outside of Aria Automation, causing discrepancies between Aria Automation and the actual resource state.

Resolution

If affected by this scenario, please open a support request and reference this KB article.