Generating a DSM Provider appliance log bundle when GUI is not available.
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Generating a DSM Provider appliance log bundle when GUI is not available.

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Article ID: 376062

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Updated On:

Products

VMware Data Services Manager

Issue/Introduction

This article outlines examples on how to use the provider_logbundle.sh script to generate a log bundle from the Provider appliance directly.  

 

Environment

VMware Data Services Manager 

Cause

During the course of troubleshooting there may be occasions where the GUI may not be accessible. This document is indented to guide the user on how to generate logs directly to further diagnose the issue.

 

Resolution

This process is run directly on the Provider Appliance by using the "provider_logbundle.sh" script.

 

  1. Log into the appliance as a root user over SSH protocol (SSH root password was specified by the user during installation) 
  2. Navigate to a preferred directory (or create a new directory) on which to generate the bundle.
  3. Execute the shell script with the following arguments:

sh /opt/vmware/tdm-provider/provider_logbundle.sh <logbundle_name> <output_directory>

 

Example only:

    • sh /opt/vmware/tdm-provider/provider_logbundle.sh logfile /tmp
      • This example shows log bundle created in tmp - /tmp/logfile.tar.gz
    • sh /opt/vmware/tdm-provider/provider_logbundle.sh systemlogs .
      • This example shows the log bundle created in current location - ./systemlogs.tar.gz

 

 

The bundle should then be downloaded from the appliance using scp/winSCP for analysis.