vCenter fresh installation failed at VCSA Stage 2 with Error : Unable to get deployment status
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vCenter fresh installation failed at VCSA Stage 2 with Error : Unable to get deployment status

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Article ID: 376053

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

This article provides a Solution so that the installation can be completed using the VAMI of the newly deployed 7.0  Appliance.

  • You're trying to install the fresh vCenter Server.
  • Trying to join an SSO domain in another network.

 

Failing at stage 2 with the below error : 

 

Stage 1 completes  :

Cause

There are multiple potential causes. Below are some examples. If you are trying to join the VCSA to an existing vSphere domain to be linked with other VCSAs (ELM), all VCSAs that are linked need to be able to resolve DNS for the linked VCSA FQDNs (forward and reverse), along with the ESX hosts and any other products they need access to. vSphere is heavily reliant on DNS resolution across the entire environment.

 

  • DNS details wrong at start of stage 1, for VCSA VM deployment.

  • Issues with firewalls/proxies/etc. blocking necessary traffic between the networks.

Resolution

Before proceeding with the VCSA deployment do the following.

 

  1. Use the below commands to make sure the VCSA FQDN (and shortname if used) is resolving from Name to IP (Forward - "A" record) and IP to Name (Reverse - "PTR" record) from the client machine you are initiating the installation from. If multiple DNS servers are configured for the VCSA, run the commands for each DNS server replacing the FQDN/IP. Do the same for the DNS server(s).

    nslookup <vcsa_FQDN> <dns_server_FQDN/IP>
    nslookup <vcsa_shortname> <dns_server_FQDN/IP>
    nslookup <vcsa_IP> <dns_server_FQDN/IP>

    nslookup <dns_server_FQDN>
    nslookup <dns_server_IP>
  2. Ping the DNS servers to confirm communication with this command on VCSA VM.

    ping <dns_server_FQDN/IP>

  3. Check the hosts file for invalid dns names.

    cat /etc/hosts
    cat /etc/resolv.conf

Make sure all the details on the "Configure network settings" page are correct.

  • Example: