Report Server cannot open the Central Configuration Manager
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Report Server cannot open the Central Configuration Manager

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Article ID: 37599

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Updated On:

Products

CA Identity Manager CA Identity Governance CA Identity Portal CA Risk Analytics CA Secure Cloud SaaS - Arcot A-OK (WebFort) CLOUDMINDER ADVANCED AUTHENTICATION CA Secure Cloud SaaS - Advanced Authentication CA Secure Cloud SaaS - Identity Management CA Secure Cloud SaaS - Single Sign On

Issue/Introduction

Problem:

From CA Identity Manager r12.6.5 to 12.6.7 tried to upgrade the the report server from 3.3 to 4.1 and the new version is not working after I finished successfully the setup.

The installation ends with no errors, but the program shows an error while we try to open the Central Configuration Manager or set up the servers on management console.

This is the screen telling that BI was installed successfully (this is in Portuguese Language saying that the installation of BI 4.1 SP5 finished successfully). PS: this problem also may happen in another languages as English. 

<Please see attached file for image>

InstalacaoReportServer21.JPG

This is not always happening. It was installed in one another VM machine and it works fine, only on customer server it crashes with error for this specific situation.

This is the error they get: 

<Please see attached file for image>

erroRptServer.JPG

The Windows is Server 2008 R2 SP1 64bit, 8gb ram

The difference of test VM and the customer server is only that one is windows is Enterprise and the customer is Standard, but this is not a restrictions in compatibility matrix

 

Resolution:

This is a known error reported by SAP support under these notes and the cause is that the correct Microsoft Visual C++ 2005 distributables are not installed.

Note1 from SAP:  1930857 - CMS failed to start after applying BI 4.1 patch. Error in Install logs. 

Link: https://websmp130.sap-ag.de/sap(bD1lbiZjPTAwMQ==)/bc/bsp/sno/ui_entry/entry.htm?param=69765F6D6F64653D3030312669765F7361706E6F7465735F6E756D6265723D3139333038353726

ps: need an registered user access in http://scn.sap.com/ to open the link 

Note 2 from SAP: 1925761 - Error "side-by-side configuration incorrect" when starting the CCM and on the Crystal Reports and Dashboards Servers in the CMC 

Link: https://websmp230.sap-ag.de/sap(bD1lbiZjPTAwMQ==)/bc/bsp/sno/ui_entry/entry.htm?param=69765F6D6F64653D3030312669765F7361706E6F7465735F6E756D6265723D3139323537363126

ps: need an registered user access in http://scn.sap.com/ to open the link

Cotent of note1 and note2 just in case you don't have access in sap Portal

1930857 from SAP:

Symptom

Central Management Server does not start after applying BI 4.1 patch on top of BI 4.0 SP05 patch 12

Following Errors are captured in the Install logs,

  • ERROR: An unexpected internal error occurred. The CMS failed to start: CreateProcess error=14001, The application has failed to start because its side-by-side configuration is incorrect. Please see the application event log or use the command-line sxstrace.exe tool for more detail. (FWM 23026)

Following error is also captured in Event Viewer's Application log.

  • Activation context generation failed for "E:\APPS\BI4\SAP BusinessObjects Enterprise XI 4.0\win64_x64\SvcMgr.exe". Dependent Assembly Microsoft.VC80.CRT,processorArchitecture="amd64",publicKeyToken="1fc8b3b9a1e18e3b",type="win32",version="8.0.50727.6195" could not be found. Please use sxstrace.exe for detailed diagnosis.

Environment

  • SAP BusinessObjects Business Intelligence 4.1
  • Windows Server

Reproducing the Issue

  1. Patch BI 4.0 SP05 with BI 4.1.
  2. The installation completes successfully.
  3. Try to start CMS, it fails.
  4. We see errors in the Event Viewer logs and install logs.

Cause

The correct Microsoft Visual C++ 2005 distributables are not installed.

Resolution

  1. Uninstall SAP BusinessObjects BI 4.1 patch. 
  2. Download and install the Microsoft Visual C++ 2005 Service Pack 1 Redistributable Package MFC Security Update x86 and x64 executables from http://www.microsoft.com/en-us/download/details.aspx?displaylang=en&id=26347.
  3. Reinstall SAP BusinessObjects BI 4.1 patch.

Note  1925761 from SAP:

Symptom

After installing SAP BusinessObjects Business Intelligence 4.x on a Windows Server any of the following errors are observed:

  • Starting the Central Configuration Manager returns “The application has failed to start because its side-by-side configuration is incorrect. Please see the application event log or use the command line sxstrace.exe tool for more detail.”
  • In the Central Management Console, the ConnectionServer and ConnectionServer32 show as “Initializing”. The Crystal Reports Cache and Processing Servers, as well as Dashboards Cache and Processing Servers show “Running with errors” and “Failed” statuses.
  • Hovering over the failed servers displays “The executable could not be launched. Possible reasons are insufficient RAM or disk space, or an invalid filepath or working directory. Actual reason: CreateProcess error=14001, The application has failed to start because its side-by-side configuration is incorrect. Please see the application event log or use the command-line sxstrace.exe tool for more detail”.
  • Manually registering the dll’s will return a “R6034, an application has made an attempt to load the C runtime library incorrectly” error.

 

Environment

  • SAP BusinessObjects Business Intelligence 4.x
  • Any supported Microsoft Windows Server version

Cause

The correct Microsoft Visual C++ 2005 distributables are not installed.

Resolution

  1. Completely uninstall SAP BusinessObjects BI 4.x. See Knowledgebase Article 1691555 - How to completely remove / uninstall SAP BO BI 4.0 from the system?
  2. Remove any Microsoft Visual C++ 2005 components currently installed.
  3. Download and install the Microsoft Visual C++ 2005 Service Pack 1 Redistributable Package MFC Security Update x86 and x64 executables from http://www.microsoft.com/en-us/download/details.aspx?displaylang=en&id=26347.
  4. Reinstall SAP BusinessObjects BI 4.x.
  5. Restart the Windows Server.

The Central Configuration Manager should now start without error and the Crystal and Dashboard Servers should be running. If the Adaptive Processing Server remains in an “Initializing” state, verify a valid license is installed in the Central Management Console.

Environment

Release: CAIDMB99000-12.6.7-Identity Manager-B to B
Component:

Attachments

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