Tasks and Process Instances Do Not Appear on both PAM Nodes
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Tasks and Process Instances Do Not Appear on both PAM Nodes

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Article ID: 375954

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Updated On:

Products

CA Process Automation Base

Issue/Introduction

In an environment with two ITPAM nodes, we see that all Tasks and Processes do not appear on both nodes in the GUI.

We checked the database and these tasks and processes are present in the database.

Environment

ITPAM 4.4 CP02

Two Nodes

Cause

Misconfiguration in OasisConfig.properties

Resolution

We found that the configuration for queues and runtime databases had an incorrect name.

We verified the following settings in CA\PAM\wildfly\standalone\.config\OasisConfig.properties:

#Defines the name of queues database.
oasis.database.queues.dbname

#Defines the name of the runtime database.
oasis.runtime.database.dbname

After correcting the name of the database we restarted services, saw that all tasks and processes had the same number in both nodes, we created a test process and saw it was seen on both nodes.