VMware Identity Manager UI is failing to load any data
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VMware Identity Manager UI is failing to load any data

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Article ID: 375863

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

You are able to successfully login to VIDM but the UI elements are blank. The navigation elements (Dashboard, Users & Groups, Catalog, Identity & Access Management, Appliance Settings, Roles) are present, but clicking on them might not lead to any data.

 

 

 

Environment

VMware Identity Manager 3.3.x

Cause

This happens if the VIDM Certificates are expired causing browser to not trust it and refuses to load

To verify the certificate expiry from a browser, follow these steps:

  • Open website: Visit the VIDM URL.
  • Click padlock: Find the padlock icon in the address bar.
  • Select Certificate: Choose "Certificate" from the options.
  • Check expiration: Look for the "Valid to" field.

Resolution

Replace the expired certificate using steps from https://docs.vmware.com/en/VMware-Aria-Suite-Lifecycle/8.18/lifecycle-install-upgrade-manage/GUID-E6243CDE-5CEA-4ABA-B6A9-71E6B58D0459.html

Note : If you are replacing a cluster setup you should also replace the certificates in the load balancer. Find the steps to replace the load balancer certificates from https://knowledge.broadcom.com/external/article?legacyId=94095 , Follow section 3. Certificate missing in the load balancer.