VMware Identity Manager UI is failing to load any data
search cancel

VMware Identity Manager UI is failing to load any data

book

Article ID: 375863

calendar_today

Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

You can successfully log in to VIDM, but the UI elements are blank. The navigation elements (Dashboard, Users & Groups, Catalog, Identity & Access Management, Appliance Settings, Roles) are visible, but clicking them might not load any data.

Environment

VMware Identity Manager 3.3.x

Cause

This issue occurs if the VIDM certificates have expired, causing the browser to distrust the connection and refuse to load the interface.

To verify the certificate expiry from a browser, follow these steps:

  • Open website: Visit the VIDM URL.
  • Click padlock: Find the padlock icon in the address bar.
  • Select Certificate: Choose Certificate from the options.
  • Check expiration: Look for the Valid to field.

Resolution

Replace the expired certificate using the steps provided in the VMware Aria Suite Lifecycle Installation, Upgrade, and Management guide.

Note: If you are replacing a cluster setup, you should also replace the certificates in the load balancer. Refer to Knowledge Base Article 94095 and follow Section 3: Certificate missing in the load balancer.