When running a CA Business Intelligence (CABI) report, the following error is received: "You do not have the right to access data returned by this universe (WIS 00504)"

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Article ID: 37581

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Updated On:

Products

SUPPORT AUTOMATION- SERVER CA Service Desk Manager - Unified Self Service KNOWLEDGE TOOLS CA Service Management - Asset Portfolio Management CA Service Management - Service Desk Manager

Issue/Introduction

Issue

 

When running a CA Business Intelligence (CABI) report, the following error is received: "You do not have the right to access data returned by this universe
(WIS 00504)"
 

Environment

 

CA Business Intelligence 4.x

Windows

 

Cause

 

There are no 'View on Demand' permissions set on the Universe and the Universe Connection used by the CABI report
 

 

Resolution

 

1.  Login to CABI Central Management Console (CMC) as Administrator
2.  Navigate to Universe
3.  Right click on the Universe that the problematic report(s) belong to and click User Security
4.  Click on the group that the user running/refreshing the report belongs to, or click Add Principals and specifically add the one user for testing purposes
5.  Whichever option you choose above, you will need to click on "Add and Assign Security"
6.  When the new window appears, click on View on Demand under Available Access Levels and click on the > arrow, then click Apply and Ok.
7.  You will need to do the same thing for the Universe Connection. From the CMC Home Screen, navigate to Connections
8.  Right click on the connection that corresponds to your Universe and click User Security
9.  Click on the group that the user running/refreshing the report belongs to, or click Add Principals and specifically add the one user for testing purposes
10.  Whichever option you choose above, you will need to click on "Add and Assign Security"
11.  When the new window appears, click on View on Demand under Available Access Levels and click on the > arrow, then click Apply and Ok.
12.  Try running/refreshing the CABI report again
 

Environment

Release: SDMU0M99000-14.1-Service Desk Manager-Full License
Component: