Failed to execute vSAN online Health Check
search cancel

Failed to execute vSAN online Health Check

book

Article ID: 375795

calendar_today

Updated On:

Products

VMware vCenter Server

Issue/Introduction

  • When executing vSAN health check

    vSAN Cluster > Montor > vSAN > Skyline Health gives the error: Unable to query vSAN health information. Check vSphere Client logs for details.

     

  • Under /var/log/vmware/vsan-health/vmware-vsan-health-service.log:

    YYYY-MM-DDTHH:MM:SS.111Z ERROR vsan-mgmt[238336] [VsanPhoneHomeSystemImpl::_ThreadMain opID=noOpId] Perform Online Health Check failure: vSAN has been disabled VMware vCenter Internet access.
    Traceback (most recent call last):
    File "bora/vsan/health/vpxd/pyMoVsan/VsanPhoneHomeSystemImpl.py", line 383, in _ThreadMain
    File "bora/vsan/health/vpxd/pyMoVsan/VsanPhoneHomeSystemImpl.py", line 340, in _checkOnlineHealthSetting
     

Environment

VMware vCenter Server 7.x

VMware vCenter Server 8.x

Cause

This issue may if the parameter  enableinternetaccess under  /etc/vmware-vsan-health/config.conf is set to false

Resolution

Follow the below  steps to resolve the issue:

Note: Take offline snapshots of vCenter prior to proceeding.  If this is an ELM configured vCenter take offline snapshots of all vCenter participating in ELM. 

  1. Log in to the vCenter Server Appliance through SSH.
  2. Type shell and press Enter
  3. Navigate to location,
    cd /etc/vmware-vsan-health
  4. Edit the config.conf file using vi editor ,
    vi config.conf
    Change the value of 'enableinternetaccess' to True.
  5. Restart vmware-vsan-health service.
  6. Login to vCenter UI and execute the vSAN Online Health Check.
  •