ImageBuilder service via VAMI reporting Running out of available disk space
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ImageBuilder service via VAMI reporting Running out of available disk space

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Article ID: 375784

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

  • vCenter Server Appliance Management Interface (VAMI) is reporting warning "Running out of available disk space"

Cause

vSphere Auto Deploy server uses the repository to store data comprising the rulesets and image profiles. Each image profile requires approximately 400 MB of cache space. By default, the allocation is 2 GB to have enough room for image profiles.

Storage cache may run out of available space when reserved space for the vSphere Auto Deploy repository starts filling up due to multiple image profiles and depots.

Resolution

In order to resolve the issue, increase the cachesize of Image Builder using either of the below options

Option 1 - Using GUI:

  • Log in to the vCenter Server UI
  • Click on the hamburger on the top left and click on Auto Deploy
  • Click on Configure
  • Click EDIT under VMware Image builder service section
  • Change the value of cacheSize_GB from 2 to 4

  • Click Save to apply the change
  • Restart the Image Builder service via VAMI 

Option 2 - Using Command Line

  • Login to vCenter server via ssh
  • Execute the below command:
        
    sed -i 's/cacheSize_GB=.*/cacheSize_GB=4/' /etc/vmware-imagebuilder/sca-config/imagebuilder-config.props
  • Restart the Image Builder service to apply the change

    service-control --restart vmware-imagebuilder

In some cases, changing the cacheSize value to 6 GB is required depending on the vSphere AutoDeploy repository size.