Unable to Add or Modify Hard Disk on VMs in vCenter Due to SSL Trust Mismatch Issues
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Unable to Add or Modify Hard Disk on VMs in vCenter Due to SSL Trust Mismatch Issues

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Article ID: 375763

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

In vCenter Server, users are unable to add a new hard disk or modify the disk size on existing virtual machines (VMs). When attempting to expand the virtual disk details, the value sets to 0 and does not allow changes.

Environment

VMware vCenter Server 7.x

Cause

SSL trust mismatch issues in the lookup service. The lookup service registrations may have an SSL trust value that does not match the MACHINE_SSL_CERT on port 443 of the node. This mismatch causes the VMware storage profile-driven service to enter a non-functional state.

Resolution

NOTE: Verify if the affected VMs have any snapshots. If VM is running on a snapshot, please consolidate and  modify the disk. If the VM is not running on the snapshot, proceed to the next step. Confirm that all VMs in vCenter exhibit the same issue, while editing VM hard disks directly from the Host Client is possible.

    1. Download and Run the LSDOCTOR tool using the command lsdoctor --trustfix on the vCenter to correct the SSL trust mismatch - https://knowledge.broadcom.com/external/article/320837/using-the-lsdoctor-tool.html
    2. Restart vCenter services after running the script to resolve the issue.
      • service-control --stop --all && service-control --start --all
    3. Verify that you were able to add or modify the disk size successfully.