The staged software disappears during the patching of a vCenter in VCF environment using async patch tool
book
Article ID: 375744
calendar_today
Updated On:
Products
VMware Cloud Foundation
Issue/Introduction
The staged software disappears during the patching of a vCenter in VCF environment using async patch tool and the task had to be restarted from the SDDC manager.
Environment
VCF
Cause
User has visited the VAMI - Software update page to check for the staged software after the patching process was initiated from the SDDC manager.
AP tool doesn't setup the repo URL. The responsibility of the AP tool is to stage the SDDC-M environment with the (customized) async patch vcf bundles. The tool uploads the VC AP bundles to the SDDC-M LCM (using API interfaces), persists to the NFS repo.
The stage is performed using the repo of SDDC manager which contains the desired patch update, the update gets staged successfully, during this period, one update folder gets created during the list operation which contains the update related binaries for that particular target version
When the VAMI - software update page is visited after the patches were staged from the SDDC repo, the list API is called again with the default URL, now this list call ends up with "No Updates found" as the source machine fails to connect to the default URL, and this list is called after the previous stage call is successful, this list call deletes the created update folder from previous list call, as it tries to search for new versions in the default URL, and when the install is called, it complains that there is no update, since the update folder is already deleted, and there was no update in the default URL.
Resolution
Refrain from visiting the VAMI - software update page during the patching. The patching progress should only be monitored from the SDDC manager in VCF environments.