Getting Error xcomd GLIBC_2.7' not found with CA XCOM for Linux r11.6 64 bit on Red Hat 5

book

Article ID: 37573

calendar_today

Updated On:

Products

CA XCOM Data Transport CA XCOM Data Transport - Linux PC

Issue/Introduction

XCOM R11.6 64 bit for Linux is installed on Red Hat 5.1 and the installation was successful, but the demon wouldn't start because of this error:

[[email protected] sbin]# xcomd
xcomd: /lib64/libc.so.6: version `GLIBC_2.7' not found (required by xcomd)
[[email protected] sbin]# ls -l /lib64/libc.so.6
lrwxrwxrwx 1 root root 11 Jul 14 2014 /lib64/libc.so.6 -> libc-2.5.so

Where is this documented?  And how to resolve this error. 

Cause

XCOM r11.6 64-Bit is compiled with glibc-2.11.1 and XCOM r11.6 32-Bit is compiled with glibc-2.3.5. 

Environment

Release: XCOM Data Transport for Linux PC 11.6 SP00
Component: xclx86

Red Hat 5.1, 6, 7, 8

Resolution

XCOM r11.6 32-Bit will run on Red hat 5. However XCOM r11.6 32-Bit, is no longer supported as of November, 2012 February 28, 2018 - End Of Service.  Please see these lifecycle dates:
https://support.broadcom.com/external/content/release-announcements/CA-XCOM-Data-Transport-Release-and-Support-Lifecycle-Dates/7809

Install XCOM r11.6 64-Bit on Red hat 6, 7 or 8.

Additional Information

Our CA XCOM product compatibility matrix specifies the supported Operating Systems for various releases of XCOM and their requirements.
See https://support.broadcom.com/download-center/solution-detail.html?aparNo=RI59036&os=LINUX for Linux.