There are User Input Requests left in the Aria Automation (vRA) GUI which cannot be deleted by the Admins
book
Article ID: 375686
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Updated On:
Products
VMware Aria Suite
Issue/Introduction
When the original vRO workflow run is deleted, trying to respond to the input request may throw an error.
When input requests are stuck unanswered and cannot be rejected or submitted, they will remain visible on the list.
Environment
VMware Aria Orchestrator 8.x
VMware Aria Automation 8.x
Cause
A network disconnect or crash can cause input requests to wind up in an invalid state.
This can also occur due to the customer's security policy.
To be able to respond to a User Input Request in Service Broker, the user needs to be a Member/Admin inside the request's project and the security assignees need to include the user or a Group, the user is a member of.
Resolution
For Administrators to see the user input requests in the User Interaction item's Options in vRO workflow, the admin needs to be in security.assignees or in security.assignee.groups
Additional Information
Please create a support request if there are UIRs that are stuck and need to be removed and reference this KB.