Vantage is hanging during LSPACE processing
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Vantage is hanging during LSPACE processing

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Article ID: 375667

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Updated On:

Products

Vantage Storage Resource Manager

Issue/Introduction

Vantage is hanging during LSPACE processing.  Normally this processing takes less than a minute, but Vantage is hanging for hours before completing its scan. 

Cause

This problem was caused by a volume (which contains the JES2 checkpoint data set) failing for some reason (possibly a SRDF sync failure). Thus JES2 could not use the checkpoint data set which limited Vantage performance (and possibly other SW performance). The LSPACE timeout was affected as well; therefore, the reserve was longer than 30 seconds, which was the requested timeout period. This caused volumes from the production system to be held until the JES2 checkpoint issue (which seems to be caused by another system, as mentioned in the restart messages) was resolved. When the JES2 issues were resolved, the long Volume/Pool scan finished within a minute, which is the usual Volume/Pool scan duration.

Resolution

To avoid this type of problem limit Vantage (and/or any LSPACE issuer) to the volumes that are part of the complex where Vantage is running.

The Vantage documentation also mentions that any volumes with critical system data sets should be excluded from LSPACE processing. See the link below, the chapter 'ENQ Conflicts and Analysis':

ENQ Conflicts and Analysis

(this doc also explains the enqueue/reserve differences and requirements).

In Vantage, volumes can be excluded from the LSPACE scan using the INCLEXCL Vantage user Parmlib member. Configuration of this information can also be done via the Vantage StoragePointâ„¢ Web Client using the Host Configuration feature of Vantage. 

Additional Information

Information on how the LSPACE macro works regarding HW reserves/enqueues can be found in the following IBM docs:

Potential problems when using RESERVE

Solving the RESERVE problems