Aria Operations UI becomes inaccessible during upgrade with the appliance reporting No network detected error
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Aria Operations UI becomes inaccessible during upgrade with the appliance reporting No network detected error

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Article ID: 375639

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

Aria operations admin UI becomes inaccessible during upgrade.  The issue occurs after nodes go down as part of the upgrade process.  When checking the appliances in vCenter we see the message No Network Detected. 

Environment

Aria Operations 8.12.x and later

Cause

The network mask has an extra dot in the vApp property example is 255.255..255.0 .  The correct vApp properties are required in order for the VMs to boot up correctly and configure it's network. 

This issue can occur also for other vApp Properties.

Resolution

  1. Take snapshot of the cluster
  2. Navigate to vCenter .
  3. Log into the vCenter UI as an Administrator.
  4. Right-Click the affected VMware Aria Operations VM and select Power > Shut Down Guest OS.
  5.  Select the affected VMware Aria Operations VM and navigate to the Configure > vApp Options tab
  6. Locate the entry for Network Mask the key should be similar to vami.netmask0.vRealize_Operations_Appliance > Select that entry > Scroll to the top of the page > Click on SET VALUE > Update the entry to the correct value
  7. Sign into the node ssh session as root 
  8. Edit the file /opt/vmware/etc/vami/ovfEnv.xml.
  9. Locate the entry with key vami.netmask0.vRealize_Operations_Appliance > Update this entry to the correct value
  10. Repeat step 2 to 9 for all affected nodes. 
  11. Bring the cluster back online 
  12. Once online apply the upgrade pak file again choosing the option to Install the PAK file even if it is already installed.