HCX plugin not working in vCenter UI
search cancel

HCX plugin not working in vCenter UI

book

Article ID: 375625

calendar_today

Updated On:

Products

VMware HCX

Issue/Introduction

  • When attempting to use the HCX Plugin via vCenter Server UI, the error below is displayed: 
    Http failure response for https://<vc-ip/fqdn>/plugins/com.vmware.hcx.plugin~4.10.0.24144741~-374630034/<hcx-ip/fqdn>-443/vsphere-client/ui/hcx/hcx-ui/rest/hybridity/api/sessions: 401 OK 


  • The following error is displayed in the /common/logs/httpd/access.log:
    <VC-IP> - - [27/Aug/2024:02:15:45 +0000] "POST /vsphere-client/ui/hcx/hcx-ui/rest/hybridity/api/sessions HTTP/1.1" 401 121 6868

 

  • The following error is displayed in the /common/logs/admin/web.log - com.vmware.vim.sso.admin.exception.NoPermissionException

2024-08-27 02:15:52.141 UTC [https-jsse-nio-127.0.0.1-8443-exec-6, , , TxId: ] INFO  c.v.vchs.hybridity.api.LoginUtil- SSO Admin URL : https://<vc-ip/fqdn>/sso-adminserver/sdk/vsphere.local, username : VSPHERE.LOCAL\Administrator
2024-08-27 02:15:52.590 UTC [https-jsse-nio-127.0.0.1-8443-exec-6, , , TxId: ] INFO  c.v.i.token.impl.SamlTokenImpl- SAML token for SubjectNameId [value=<account-used-to-register-VC-with-HCX>, format=http://schemas.xmlsoap.org/claims/UPN] successfully parsed from XML
2024-08-27 02:15:52.702 UTC [https-jsse-nio-127.0.0.1-8443-exec-6, , , TxId: ] ERROR c.v.v.h.a.AccessTokenRestController- Failed to fetch NSP roles
com.vmware.vim.sso.admin.exception.NoPermissionException: null

 

Environment

HCX
vCenter Server

Cause

The account used to register vCenter via the HCX Admin UI was not part of the vSphere Administrators group, resulting in a 401 error being displayed on the UI.

Resolution

Add the user to the Administrators group, or modify the HCX configuration to use a user that is already part of the Administrators group.

  • To update or modify the account used by HCX, access the appliance management interface at https://<hcx-ip-or-fqdn>:9443 and navigate to Configuration -> vCenter Server, and click on 'Edit':




  • Restart the Appliance Management and Web Management from "Appliance Summary" page.
  • Log out and then log back in to the vCenter UI.

Additional Information

The account used to register vCenter via HCX Admin UI page must belong to the vSphere administrators group and have the administrator role assigned.
For more information, check HCX Manager User Account and Role Requirements