Broadcom API Portal 5.3 - Deleted API Proxy's name cannot be reused
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Broadcom API Portal 5.3 - Deleted API Proxy's name cannot be reused

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Article ID: 375621

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Updated On:

Products

CA API Developer Portal

Issue/Introduction

If I add a new API proxy with the same name of a proxy previously deleted, Portal UI fails with an error.

Environment

API Portal 5.3

Cause

When deleting an existing proxy, the key store is not automatically removed from Portal's database's table portal.KEY_STORE. That causes an issue where we cannot reuse the same name when creating a new Proxy (since the item still exists in the database).

Resolution

We need to remove the keystore of the deleted API Proxy using one of the following two methods:

Option 1 (recommended method):

From Portal UI > Manage Keystore

 

From the list, click on the "proxy name-keystore" that we intend to remove, then hit the Delete button and Confirm the action.

 

Option 2:

From the database.

1. List all Proxy names currently saved in the Portal DB KEY_STORE table:

select UUID, NAME from portal.KEY_STORE;

2. Identify the UUID of the affected Proxy name and delete using the below statement (insert correct UUID):

delete from portal.KEY_STORE where UUID = 'xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxx';