The SPE service appears to be running but is not listening on the configured port
search cancel

The SPE service appears to be running but is not listening on the configured port

book

Article ID: 375608

calendar_today

Updated On:

Products

Protection Engine for Cloud Services

Issue/Introduction

After staring/restarting Symantec Protection Engine (SPE) service the service appears up but is not listening on the configured port.  A review of the <SPE_INSTALL_FOLDER>/SymantecProtectionEngineAbortLog.txt shows entries similar to the following.

400 CSAPI failed to initialize : Failed to get virtual definitions from Controller service.
0 Symantec Protection Engine is shutting down; logs may contain more information.

Cause

SPE 9.x introduced "virtual definitions" which allowed a separate "controller" service to handle virus definitions updates instead of the SPE process.  If the port used by the "controller" service is already in use, then the "controller" service and SPE will be unable to communicated causing the errors noted above.

Resolution

Disabling the "virtual definitions" will cause the SPE service to handle virus definition updates and will disable the "controller" service.  The "virtual definitions" can be disabled by performing the following steps.

  1. Log in to the CLI of the SPE
  2. Navigate to the <SPE_INSTALL_FOLDER>
  3. Issue the following command:
    ./xmlmodifier -s /configuration/Resources/System/VirtualHome/@enabled false configuration.xml
  4. Restart the SPE service