Workload summary shows alert "License check: There are no assigned licenses found for this product"
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Workload summary shows alert "License check: There are no assigned licenses found for this product"

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Article ID: 375501

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Updated On:

Products

VMware vCenter Server VMware SDDC Manager

Issue/Introduction

- Alert "License check: There are no assigned licenses found for this product" was seen in 4.x and Upgrade doesnt fix too.

Environment

VCF 4.x

VCF 5.x

Cause

SSH to SDDC manager there are such errors in /log/vmware/vcf/operationsmanager/operationsmanager.log,

2024-04-22T06:03:05.608+0000 ERROR [vcf_om,3f929f1ad5984d9e,1dcf] [c.v.v.l.s.u.ResourceLicensingPopulator,om-exec-3] License assignment not found for resource esxi01.abc.local
2024-04-22T06:03:05.712+0000 ERROR [vcf_om,3f929f1ad5984d9e,1dcf] [c.v.v.l.s.u.ResourceLicensingPopulator,om-exec-3] License assignment not found for resource esxi02.abc.local
2024-04-22T06:03:05.809+0000 ERROR [vcf_om,3f929f1ad5984d9e,1dcf] [c.v.v.l.s.u.ResourceLicensingPopulator,om-exec-3] License assignment not found for resource esxi03.abc.local
2024-04-22T06:03:05.887+0000 ERROR [vcf_om,3f929f1ad5984d9e,1dcf] [c.v.v.l.s.u.ResourceLicensingPopulator,om-exec-3] License assignment not found for resource esxi04.abc.local

By checking SDDC web page -> Inventory -> Hosts -> ALL HOSTS, the hosts are,
esxi01.abc.local
esxi02.abc.local
esxi03.abc.local
esxi04.abc.local

However in vCenter web client, click the Main menu -> Administration -> Licensing -> Licenses -> Assets -> Hosts, we see the hosts are in capital case,
ESXi01.abc.local
ESXi02.abc.local
ESXi03.abc.local
ESXi04.abc.local

In VCF, when checking the license status for a resource, the data is retrieved from vCenter using the resource name. During this process, VCF does not differentiate between uppercase and lowercase letters in the name. Consequently, if there is a case difference between the hostnames in VCF and those in vCenter, the license status for the hosts may not be fetched.

Resolution

Although this situation results in an error message, it does not block any operations or cause other issues.

Therefore, the error can be safely ignored
- or 
We can resolve this by renaming the hostname in the SDDC inventory.

First, ensure that the hostname displayed in vCenter matches the FQDN of the ESXi hosts by verifying it directly on the ESXi servers.
If the names match, reach out to Vmware by Broadcom support 

The rename operation, is a SDDC DB edit, and we STRONGLY recommend:
- involving Vmware by Broadcom Support
- snapshot/ backup needs to be available 


1. verify which hosts are impacted 
# grep -i "License assignment not found for resource" operationsmanager.log | awk '{print $11}' | sort | uniq -c | less -iN
      1       6 esxi01.abc.local   
      2       3 esxi02.abc.local 
      3       5 esxi03.abc.local
     
4       5 esxi04.abc.local  

2. Reach out to VMware by Broadcom support for the SDDC DB edit