Workload Domain summary shows alert "License check: There are no assigned licenses found for this product"
search cancel

Workload Domain summary shows alert "License check: There are no assigned licenses found for this product"

book

Article ID: 375501

calendar_today

Updated On:

Products

VMware vCenter Server VMware SDDC Manager

Issue/Introduction

  • Alert "License check: There are no assigned licenses found for this product" is seen in 4.x and upgrade does not fix the issue.

Environment

VCF 4.x

VCF 5.x

Cause

  • In VCF, when checking the license status for a resource, the data is retrieved from vCenter using the resource name. During this process, VCF does not differentiate between uppercase and lowercase letters in the name. Consequently, if there is a case difference between the hostnames in VCF and those in vCenter, the license status for the hosts may not be fetched.

  • Errors in /log/vmware/vcf/operationsmanager/operationsmanager.log

    YYYY-MM-DDTHH:MM:SS ERROR [vcf_om,3f929f1ad5984d9e,1dcf] [c.v.v.l.s.u.ResourceLicensingPopulator,om-exec-3] License assignment not found for resource esxi01.example.local
    YYYY-MM-DDTHH:MM:SS ERROR [vcf_om,3f929f1ad5984d9e,1dcf] [c.v.v.l.s.u.ResourceLicensingPopulator,om-exec-3] License assignment not found for resource esxi02.example.local
    YYYY-MM-DDTHH:MM:SS ERROR [vcf_om,3f929f1ad5984d9e,1dcf] [c.v.v.l.s.u.ResourceLicensingPopulator,om-exec-3] License assignment not found for resource esxi03.example.local
    YYYY-MM-DDTHH:MM:SS ERROR [vcf_om,3f929f1ad5984d9e,1dcf] [c.v.v.l.s.u.ResourceLicensingPopulator,om-exec-3] License assignment not found for resource esxi04.example.local

Checking SDDC web page -> Inventory -> Hosts -> ALL HOSTS, the hosts are in lowercase:
esxi01.example.local
esxi02.example.local
esxi03.example.local
esxi04.example.local

However in vCenter web client, click the Main menu -> Administration -> Licensing -> Licenses -> Assets -> Hosts, the hosts are in uppercase:
ESXi01.example.local
ESXi02.example.local
ESXi03.example.local
ESXi04.example.local

 

Resolution

  • Although this situation results in an error message, it does not block any operations or cause other issues. Therefore, the error can be safely ignored.
    OR
  • This can be resolved by renaming the hostname in the SDDC inventory.
    • First, ensure that the hostname displayed in vCenter matches the FQDN of the ESXi hosts by verifying it directly on the ESXi servers. If the names match, reach out to Broadcom Support
    • The rename operation is a SDDC Database edit. Ensure to take a backup/snapshot of the SDDC Manager.

      1. Verify which hosts are impacted by running the below command
      # grep -i "License assignment not found for resource" operationsmanager.log | awk '{print $11}' | sort | uniq -c | less -iN
            1       6 esxi01.example.local   
            2       3 esxi02.example.local 
            3       5 esxi03.example.local
            4       5 esxi04.example.local  

      2. Reach out to Broadcom Support for the SDDC Database edit.