Alert "License check: There are no assigned licenses found for this product" is shown in Workload Domain summary
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Alert "License check: There are no assigned licenses found for this product" is shown in Workload Domain summary

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Article ID: 375501

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Updated On:

Products

VMware vCenter Server VMware SDDC Manager

Issue/Introduction

  • Alert "License check: There are no assigned licenses found for this product" is seen in SDDC Manager and upgrade does not fix the issue.

  • Errors in SDDC Manager - /log/vmware/vcf/operationsmanager/operationsmanager.log

    YYYY-MM-DDTHH:MM:SS ERROR [vcf_om,3f929f1ad5984d9e,1dcf] [c.v.v.l.s.u.ResourceLicensingPopulator,om-exec-3] License assignment not found for resource esxi01.example.local
    YYYY-MM-DDTHH:MM:SS ERROR [vcf_om,3f929f1ad5984d9e,1dcf] [c.v.v.l.s.u.ResourceLicensingPopulator,om-exec-3] License assignment not found for resource esxi02.example.local
    YYYY-MM-DDTHH:MM:SS ERROR [vcf_om,3f929f1ad5984d9e,1dcf] [c.v.v.l.s.u.ResourceLicensingPopulator,om-exec-3] License assignment not found for resource esxi03.example.local
    YYYY-MM-DDTHH:MM:SS ERROR [vcf_om,3f929f1ad5984d9e,1dcf] [c.v.v.l.s.u.ResourceLicensingPopulator,om-exec-3] License assignment not found for resource esxi04.example.local

  • Checking SDDC web page -> Inventory -> Hosts -> ALL HOSTS, the hosts are in lowercase:

    esxi01.example.local
    esxi02.example.local
    esxi03.example.local
    esxi04.example.local

  • However in vCenter web client, click the Main menu -> Administration -> Licensing -> Licenses -> Assets -> Hosts, the hosts are in uppercase:

    ESXi01.example.local
    ESXi02.example.local
    ESXi03.example.local
    ESXi04.example.local

Environment

  • VCF 4.x
  • VCF 5.x

Cause

In VCF, when checking the license status for a resource, the data is retrieved from vCenter using the resource name. During this process, VCF does not differentiate between uppercase and lowercase letters in the name. Consequently, if there is a case difference between the hostnames in VCF and those in vCenter, the license status for the hosts may not be fetched. It can in certain situations block the upgrade workflow.

Resolution

This can be resolved by renaming the hostname in the SDDC inventory.

Prerequisites:

  • Ensure that the hostname displayed in vCenter matches the FQDN of the ESXi hosts by verifying it directly on the ESXi servers. If the names match, reach out to Broadcom Support

  • The rename operation is a SDDC Database edit. Ensure to take a backup/snapshot of the SDDC Manager.

    • Verify which hosts are impacted by running the below command:

      grep -i "License assignment not found for resource" /var/log/vmware/vcf/operationsmanager/operationsmanager.log | awk '{print $11}' | sort | uniq -c | less -iN

      1       6 esxi01.example.local
      2       3 esxi02.example.local
      3       5 esxi03.example.local
      4       5 esxi04.example.local

Resolution:

  1. SSH to the SDDC Manager appliance and access the BASH shell

  2. Access the postgres platform database:

    psql -U postgres -h localhost -d platform

  3. Run the following command to list the host with ID's from the host table:

    SELECT id, hostname from host;

  4. Once you have a list of the hostnames and ID's, you will update the ID with the lowercase value:

    update host set hostname='esxi01.example.com' where id='514ccc29-2f8c-4737-8114-db82d0dd39be';

  5. \q to exit the postgres instance
  6. Refresh the SDDC manager browser session and the hostname will be reflected in lowercase and the error should no longer be present.

Additional Information

For the holistic health of the environment, lowercase is the recommended case for the environment. If you find that you have mixed case hostname / FQDN in your SDDC environment it is recommended that you take the following additional steps:

  • Change the ESX hostname to lowercase on the host
  • Make sure that DNS for forward and reverse also reflects lowercase
  • The SDDC will create an account on the host, after changing to lowercase it is recommended to re-create this account for case consistency