Service Desk Manager service is not starting
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Service Desk Manager service is not starting

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Article ID: 375465

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Updated On:

Products

CA Service Desk Manager CA Service Management - Service Desk Manager ServiceDesk

Issue/Introduction

During a disaster recovery drill the SDM Server will not start.  In the "Services" window, status hangs with "Starting" and never completes the startup process.

Rebooting the system did not resolve the problem

 

Environment

Service Desk Manager 17.x

Cause

In the stdlog.x:

08/23 20:24:03.70 <sdmserver> pdm_d_mgr               6932 SIGNIFICANT  ntservice.c            311 Command return non-zero exit code. Command: sql_check_db  -c. Exit Code: 99
08/23 20:24:03.72 <sdmserver> pdm_d_mgr               6932 SIGNIFICANT  mgr_os_if.c           2967 Unable to connect to SQL Server database mdb on server <sqlserver server>

Checking checkdb.0 we find:

08/23 21:03:40.51 <sdmserver> sql_ckeckdb             8652 ERROR        sqlclass.c             479 Failed to logon to SQL Server (<sqlserver server) Reason: [Microsoft SQL Server Native Client 10.0] [ SQL Code=-2146893007 SQL State=08001] A network-related or instance-specific error has occurred while establishing a connection to SQL Server. Server is not found or not accessible. Check if instance name is correct and if SQL Server is configured to allow remote connections. For more information see SQL Server Books Online.; [Microsoft SQL Server Native Client 10.0] [ SQL Code=-2146893007 SQL State=08001] SSL Provider: The client and server cannot communicate, because they do not possess a common algorithm.  ; [Microsoft SQL Server Native Client 10.0] [ SQL Code=21 SQL State=08001] Client unable to establish connection; [Microsoft SQL Server Native Client 10.0] [ SQL Code=21 SQL State=08001] Encryption not supported on the client.

SDM was having trouble connecting to the SQL Server database.

SQL Server database version is 2016.  SQL Server components on the SDM server were at v2008.

TLS had been enabled on the SQL Server host and the SQL Server components on the SDM server were no longer able to communicate.

Resolution

Disabling TLS on the SQL Server host resolved the problem and Service Desk was able to start up after that.

Additional Information

We recommended that the version of SQL Server components on the SDM server be at the same version level as the Service Desk database server's version.  You may make fresh downloads of the SQL Server components from the links in the SDM documentation: Database Requirements - CA Service Desk Manager (SDM)