"upstream connect error or disconnect/reset before headers" error when accessing SRM/vSphere Replication/dr page URL
book
Article ID: 375425
calendar_today
Updated On:
Products
VMware Live Recovery
Issue/Introduction
Symptoms:
Site Recovery Manager (SRM) or vSphere Replication (VR) plugin in vCenter ( VC) reads "UI error: Unknown error"
On accessing the /dr URL page manually we receive browser error, ie: https://Appliance_FQDN/dr
Error seen - "upstream connect error or disconnect/reset before headers. reset reason: connection failure, transport failure reason: delayed connect error: 111"
Environment
VMware vSphere Replication
VMware Live Site Recovery
Cause
The appliance dr-client service is hung or in stopped state.
Example:
Note: Since the Startup Type of the service is "Manual", it will not auto start the service post appliance reboot. So, this service needs to be started manually. dr-client service is responsible from SRM/DR UI on the browser.
Resolution
Follow below steps -
Launch Site Recovery Manager (SRM) or vSphere Replication VR) Manager VAMI 5480 page