Unable to view another vCenter in Linked mode
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Unable to view another vCenter in Linked mode

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Article ID: 375416

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

  • When logged into vCenter A via the vSphere UI, vCenter B is visible, but when logged into vCenter B, vCenter A is not visible
  • On /var/log/vmware/vsphere-ui/logs/vsphere_client_virgo.log we see login vCenterA tries to login to vCenterB but fails:

YYYY-MM-DDThh:mm:ss.994+07:00] [INFO ] vim-authentication-pool-107 700000## 1000## 2000## com.vmware.vise.vim.commons.vcservice.impl.LinkedVcGroupImpl Created a linked VC group: [https://vCenterA:443/sdk (b876d3c9-6402-42bf-b9a4-6fbf4####), https://vCenterB:443/sdk (86c49909-099e-45b3-9927-67c1f83f94###] Startup VC: https://vCenterA:443/sdk (b876d3c9-6402-42bf-b9a4-6fbf42a7e###)

[YYYY-MM-DDThh:mm:ss.033+07:00] [ERROR] linkedVcGroup-pool-108 700000## 1000## 2000## com.vmware.vise.util.concurrent.ExecutorUtil A task crashed: com.vmware.vise.vim.commons.vcservice.impl.LinkedVcGroupImpl$1@4b81### java.util.concurrent.ExecutionException: (vim.fault.InvalidLogin) { faultCause = null,faultMessage = null Caused by: com.vmware.vim.binding.vim.fault.InvalidLogin: Cannot complete login due to an incorrect user name or password.

  • On var/log/vmware/vpxd/vpxd.log on vCenterB we see the login request but with a slightly different timestamp (either delayed or earlier than what is seen in above entries):

YYYY-MM-DDThh:mm:ss.263+07:00 info vpxd[05600] [Originator@6876 sub=vpxLro opID=###3i72g-290-auto-8a-h5:70000013-##] [VpxLRO] -- BEGIN lro-8259 -- SessionManager -- vim.SessionManager.loginByToken -- ###be21d-b92c-adf1-4145-1eadb7ed3###
YYYY-MM-DDThh:mm:ss.264+07:00 error vpxd[05600] [Originator@6876 sub=MoSessionMgr opID=###3i72g-290-auto-8a-h5:70000013-##] [SessionManagerMo::LoginByToken] Couldn't find the SAML token due to N9SsoClient14ParseExceptionE(Token start date is in the future

Environment

vCenter Server 7.x , 8.x

 

Cause

Issue is observed due to time skew between linked vCenter Servers causing the login request failure.

 

Resolution

Fix the time skew between the vCenter Servers by configuring the time settings properly on all the linked vCenters so that they are in sync. For more information, please follow the below article:

Configure Network Time Protocol (NTP) on the vCenter

Additional Information