VAMI backup of vCenter fails after a long time with large size, but has DNS error in backup log
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VAMI backup of vCenter fails after a long time with large size, but has DNS error in backup log

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Article ID: 375361

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

Found in backup log (usually found here: /var/log/vmware/applmgmt/backup.log):


2024-08-08T12:15:51.955 [20240808-115734-22837322] [MainProcess:PID-14754] [Net::GetPNIDAddrInfo:Net.py:639] INFO: PNID 'vCenter FQDN' is resolved with addresses: ['XXX.XX.XX.XX']
2024-08-08T12:15:51.956 [20240808-115734-22837322] [MainProcess:PID-14754] [BackupManager::GenerateBackupMetadata:BackupManager.py:202] ERROR: PNID is not resolvable to any IP on theexisting system
2024-08-08T12:15:51.956 [20240808-115734-22837322] [MainProcess:PID-14754] [BackupManager::main:BackupManager.py:592] ERROR: BackupManager encountered an exception: name 'MetadataException' is not defined

Environment

vsphere 7.x

Cause

DNS settings are not correct for vCenter and need to be corrected in the customer environment

Resolution

Run the following commands to verify customer DNS setup.

 

- Check Forward and Reverse DNS Resolution for this VC PNID and share the output.
# nslookup <vCenter FQDN> <vCenter IP address> 
# nslookup <DNS server> <vCenter IP address>
# nslookup <vCenter FQDN> <vCenter IP address>

- Share the output of:
# hostname -f
# cat /etc/hostname
# /usr/lib/vmware-vmafd/bin/vmafd-cli get-pnid --server-name localhost

Both forward and reverse DNS resolution should be accurate, and should match the vCenter PNID and the IP address on the Primary vmnic on the vCenter VM.

 

Additional Information

This backup issue is essentially caused due to this secondary interface and IP, and the resolution surrounding it.