VMware Aria Suite Lifecycle times out with error code LCMVRACONFIG50008 when attempting to upgrade VMware Aria Automation 8.x to a later version
search cancel

VMware Aria Suite Lifecycle times out with error code LCMVRACONFIG50008 when attempting to upgrade VMware Aria Automation 8.x to a later version

book

Article ID: 375269

calendar_today

Updated On:

Products

VMware Aria Suite

Issue/Introduction

  • You are upgrading VMware Aria Automation 8.16 or higher to a later version.
  • You receive the following error during the upgrade attempt:
    Error Code: LCMVRACONFIG50008
    Check VMware Aria Automation hostname is resolvable and reachable

Environment

  • VMware Aria Automation 8.16 and later

Cause

  • In some cases, VMware Aria Suite Lifecycle attempts to contact VMware Aria Automation before it is ready, causing a terminating error in the upgrade workflow. In contrast, Aria Automation is still processing the upgrade request.

Resolution

  • Prerequisites

    • You have manual backups prior to the automatic backups Aria Suite Lifecycle takes during the upgrade process
    • You have access to utilities to connect over SSH with access to root username and password.
    • Ensure the following article is followed before proceeding with any future upgrades: Steps for removing weak SHA1 algorithms and ciphers from VMware Aria Products
    • Ensure root passwords for each appliance been recently updated prior to upgrade.

    Procedure

    • SSH into one of the Aria Automation appliances and run the following command to validate that the upgrade is running.
      • vracli upgrade status
    • Verify Kubernetes is initializing containers and pods:
      • kubectl -n prelude get pods
    • Follow the upgrade process by running:
      • vracli upgrade status --follow
      • The following message is expected:
        Deploying Services. This might take a few minutes.
    • Once the system has successfully made it through deploying services, retry the upgrade, without reverting to snapshots, within Aria Suite Lifecycle to complete the upgrade workflow.
    • The upgrade will complete successfully.

Additional Information

  • If the Aria Automation upgrade continues to fail, use the below article to troubleshoot further then open a Service Request with VMware by Broadcom for additional assistance.

Troubleshooting VMware Aria Automation 8.x (formerly vRealize Automation 8.x) upgrades