Password expired alarm
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Password expired alarm

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Article ID: 375200

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Updated On:

Products

VMware NSX

Issue/Introduction

Title: Alarm for Password Expired
Event ID: password_management.password_expired

Alarm Description:

  • Purpose: Reporting password of node local user account is expired.

Environment

VMware NSX-T Data Center
VMware NSX

Cause

NSX local user password is expired, because password was not reset as per the NSX password policy.

Resolution

Steps to Resolve
For version 3.0.0 and above

Recommended Action:

  • When alarm password_management.password_expired is raised, user will be notified with following message:

    The password for user {username} has expired.

  • In order to address this alarm, resetting password for user account is required.

    Password of user account can be changed via different methods:

    1. Using NSX UI
      1. Try logging into NSX UI and it will redirect user to password reset page.
      2. Enter correct Current Password and New password as per configured password policy.
    2. Using NSX CLI
      1. Try logging into NSX CLI using console or SSH into appliance with valid current password,
      2. user will be prompted to reset the new password.
    3. Using API

      Invoke following API with valid request body, to reset the password of user account

      [PUT] /api/v1/node/users/<userid> where <userid> is the ID of the user.

      Refer NSX API guide for more information.
  • Once password is updated for the user, alarm is resolved with following message:

    The password for user {username} has been changed successfully or is no longer expired or the user is no longer active.

Note: Users with expired passwords cannot access NSX environment.

Maintenance window required for remediation? No

Additional Information