ESXi 8.x to 8.0U3 Update Fails with PSOD on HPE ProLiant Servers: 'GP Exception 13: MemHwCounter'
search cancel

ESXi 8.x to 8.0U3 Update Fails with PSOD on HPE ProLiant Servers: 'GP Exception 13: MemHwCounter'

book

Article ID: 375179

calendar_today

Updated On:

Products

VMware vSphere ESXi 8.0

Issue/Introduction

  • During the update from ESXi versions prior to 8.0U3 (e.g., 8.x) to ESXi 8.0U3, HPE ProLiant servers experience a PSOD. This issue occurs specifically when upgrading to ESXi 8.0U3 and does not happen during minor updates within the same release series (e.g., 8.0U1 -> 8.0U2)
  • The backtrace appears similar to the following:

YYYY-MM-DD-THH:MM:SS cpu35:2098595)World: 3355: PRDA 0x420048c00000 ss 0x0 ds 0x750 es 0x750 fs 0x750 gs 0x750
YYYY-MM-DD-THH:MM:SS cpu35:2098595)World: 3357: TR 0x758 GDT 0x4538c0253888 (0xffff) IDT 0x42003009d000 (0xffff)
YYYY-MM-DD-THH:MM:SS cpu35:2098595)World: 3359: CR0 0x8001003d CR3 0x58462000 CR4 0x14216c
YYYY-MM-DD-THH:MM:SS cpu35:2098595)Backtrace for current CPU #35, worldID=2098595, fp=0x41ffefaea100
YYYY-MM-DD-THH:MM:SS cpu35:2098595)0x45396761be90:[0x42002fbc84e8]MemHwCounters_ProgramEvent@vmkernel#nover+0x7c stack: 0x2, 0x0, 0x0, 0x42002fbc8570, 0x0
YYYY-MM-DD-THH:MM:SS cpu35:2098595)0x45396761bec0:[0x42002fbc856f]MemHwCounters_Freeze@vmkernel#nover+0x78 stack: 0x45396761bfd0, 0x45396761f100, 0x0, 0x42002fbc87fc, 0x0
YYYY-MM-DD-THH:MM:SS cpu35:2098595)0x45396761bef0:[0x42002fbc87fb]MemHwCounters_ContinuousMonitor@vmkernel#nover+0x74 stack: 0x0, 0x0, 0x0, 0x0, 0x0
YYYY-MM-DD-THH:MM:SS cpu35:2098595)0x45396761bfe0:[0x4200300d67b2]CpuSched_StartWorld@vmkernel#nover+0xbf stack: 0x0, 0x42002fb44c70, 0x0, 0x0, 0x0
YYYY-MM-DD-THH:MM:SS cpu35:2098595)0x45396761c000:[0x42002fb44c6f]Debug_IsInitialized@vmkernel#nover+0xc stack: 0x0, 0x0, 0x0, 0x0, 0x0
YYYY-MM-DD-THH:MM:SS. cpu35:2098595)VMware ESXi 8.0.3 [Releasebuild-24022510 x86_64]
#GP Exception 13 in world 2098595:memhwcounter @ 0x42002fbc84e8


 

 

Environment

  • VMware vSphere ESXi 8.0 U3
  • HPE ProLiant servers

Cause

On ESXi hosts that use the SNC technology, if the CPU is not manufactured with equal number of cores per sub-NUMA cluster, or some cores are deactivated from the BIOS, the host fails to boot with a purple diagnostic screen post upgrade to ESXi 8.0 Update 3.

Resolution

This issue is addressed in ESXi 8.0.3e (Build Number 24674464). For more details, please refer to VMware ESXi 8.0 Update 3e Release Notes