Incorrect Day Displayed for Child Task Timestamps in AWI when Client is configured with CET Time Zone
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Incorrect Day Displayed for Child Task Timestamps in AWI when Client is configured with CET Time Zone

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Article ID: 375085

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Updated On:

Products

CA Automic Workload Automation - Automation Engine Automic SaaS CA Automic One Automation

Issue/Introduction

The UC4 Client is configured to run on a CET Time zone and when viewing the execution history, specifically the "Last Monitor" of a workflow, the start and end time timestamps for the child tasks display an incorrect "Day."

This behavior is consistent across both Jetty and Tomcat servers. 

This happens when the start time of the child task falls between 00:00 -> 02:00 AM

If the tasks start post 02:00 AM the issue does not appear

Example: The highlighted square’s in RED show the incorrect “Day” between 00:00 -> 02:00 AM CET and when the start time is post 02:00 CET the correct "Day" is displayed.

 

 

Environment

Release: 21.x 24.x

Component: Automic Web Interface

Cause

The issue has been confirmed to be a bug by our Dev team, a fix will be provided in a future version.

Resolution

Update to a fix version listed below or a newer version if available.

Fix version:

Component(s): Automic Web Interface

Automic Web Interface 21.0.12  - Available

Automic Web Interface 24.2.0  - Available