Advanced Reporting - Not able to load reports
book
Article ID: 375051
calendar_today
Updated On:
Products
Clarity PPM On Premise
Clarity PPM SaaS
Issue/Introduction
Scenario under consideration:
- Advanced Reporting loads without issues (Home -> Advanced Reporting)
- It is possible to navigate to various folders using 'View -> Repository' from the menu
- However, when a report execution is attempted, by clicking on a report, the report does not load
- Input controls do not load either
- The screen just shows a spinning wheel
Environment
- Jaspersoft 8.1.1
- Clarity 16.2.1
- Clarity App deployed behind a Load Balancer
- HTTPS implemented for the Load Balancer URL
- Clarity App web server communicates only through HTTP
Cause
- Browser Network Trace, via Developer Console shows that the HTTP request made to execute the report gets blocked
- NSA -> Properties -> Applications sub tab -> SSL Handling = Support both HTTP and HTTPS without switching.
Resolution
- Since HTTPS is implemented only on the load balancer URL, the NSA / CSA setting can be as follows:
- NSA -> Properties -> Applications sub tab -> SSL Handling = Derive from Port Settings.
Feedback
thumb_up
Yes
thumb_down
No