SDDC Manager Upgrade to 5.2 Fails During "Update VCF Service and Platform rpms" Stage
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SDDC Manager Upgrade to 5.2 Fails During "Update VCF Service and Platform rpms" Stage

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Article ID: 374980

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Updated On:

Products

VMware SDDC Manager

Issue/Introduction

During the upgrade process from SDDC Manager versions 4.X or 5.X to version 5.2, the upgrade may fail at the stage "Update VCF Service and Platform rpms."

This issue is typically indicated by errors related to missing packages in the target repository.

The error message can be found in log files located at /var/log/vmware/capengine/cap-update/install-<Time_&_Date> and reads:

Error: Packages - json-glib - are not available in the target repo for OS upgrade. Please provide the correct repo having the required packages.
Cannot continue. Aborting.

 

Environment

Environments being upgraded from SDDC Manager versions 4.X or 5.X to version 5.2.

Cause

The failure is caused by RPMs on the current SDDC Manager being incompatible with those required for the upgrade to version 5.2.

Resolution

To resolve this issue, follow these steps:

 
  • Confirm Package Existence :

    rpm -qa | grep -i json-glib

  • Take a Snapshot of SDDC Manager :

    Ensure that you have taken a snapshot of the current state of the SDDC Manager and that backups are available.

  • Remove Incompatible RPM via CLI : Use tdnf to remove the incompatible package:

    tdnf remove json-glib -y

If this command fails, use the following workaround:

rpm -e json-glib syslog-ng

  • Retry Upgrade :

    After removing the incompatible package(s), retry the upgrade process.

 

Reference Screenshots:

 

Additional Information

If you encounter issues with tdnf failing to synchronize cache due to SSL errors or other connectivity problems, refer to this GitHub issue for additional guidance: https://github.com/vmware/photon/issues/400


Successful Example:

root@hostname[ /home/vcf ]# tdnf remove json-glib -y
Refreshing metadata for: 'VMware Photon Linux 3.0 (x86_64) Updates'
retrying 1/10
..........

Error(1236) : SSL connect error
Error: Failed to synchronize cache for repo 'VMware Photon Linux 3.0 (x86_64) Updates' from 'https://packages.vmware.com/photon/3.0/photon_updates_3.0_x86_64 [packages.vmware.com]'
Disabling Repo: 'VMware Photon Linux 3.0 (x86_64) Updates'
Refreshing metadata for: 'VMware Photon Linux 3.0 (x86_64)'
retrying 1/10
...........

Error(1236) : SSL connect error
Error: Failed to synchronize cache for repo 'VMware Photon Linux 3.0 (x86_64)' from 'https://packages.vmware.com/photon/3.0/photon_release_3.0_x86_64 [packages.vmware.com]'
Disabling Repo: 'VMware Photon Linux 3.0 (x86_64)'
Refreshing metadata for: 'VMware Photon Extras 3.0 (x86_64)'
retrying 1/10
............

Error(1236) : SSL connect error
Error: Failed to synchronize cache for repo 'VMware Photon Extras 3.0 (x86_64)' from 'https://packages.vmware.com/photon/3.0/photon_extras_3.0_x86_64 [packages.vmware.com]'
Disabling Repo: 'VMware Photon Extras 3.0 (x86_64)'
 
Removing:
json-glib                                     x86_64                 1.4.4-1.ph3                    @System                 490.35k 502121
 
Total installed size: 490.35k 502121
Testing transaction
Running transaction
Removing: json-glib-1.4.4-1.ph3.x86_64
 
Complete!

If the similar logs are found as below, then follow the same above steps to remove the dotnet-runtime and libunwind incompatible RPM packages and proceed with the upgade.

From /var/log/vmware/capengine/cap-update/install-XXXXXX.log
YYYY-MM-DDTHH:MM:SS+00:00 Error: Packages - dotnet-runtime libunwind - are not available in the target repo for OS upgrade. Please provide the correct repo having the required packages.
Original list of RPMs and RPM DB are stored in /tmp/photon-upgrade.sh-XXXX-XX-XX-XX-XX-XX,  please provide contents of that folder along with system journal   logs for analysis; these logs can be captured using command-
# /usr/bin/journalctl -xa > /tmp/photon-upgrade.sh-XXXX-XX-XX-XX-XX-XX/journal.log
Cannot continue. Aborting.

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If the above steps do not resolve the issue, collect a fresh SoS bundle from the SDDC Manager and contact Broadcom support for further assistance.