SDDC Manager Upgrade to 5.X Fails During "Update VCF Service and Platform rpms" Stage
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SDDC Manager Upgrade to 5.X Fails During "Update VCF Service and Platform rpms" Stage

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Article ID: 374980

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Updated On:

Products

VMware SDDC Manager

Issue/Introduction

  • During the upgrade process from SDDC Manager versions 4.X or 5.X to version 5.X, the upgrade may fail at the stage "Update VCF Service and Platform rpms."
  • On the /var/log/vmware/capengine/cap-update/install-#### we see entries similar to below:

YYYY-MM-DDThh:mm:ss+0000 Upgrading Photon OS to 4.0 from 3.0
1. package <pkg_name1(s)> requires <pkg_name2(s)>(64bit), but none of the providers can be installed
Found 1 problem(s) while resolving
Error(1301) : Solv general runtime error
Refreshing metadata for: 'Appliance Photon RPMs'
YYYY-MM-DDThh:mm:ss+0000 Error in upgrading to Photon OS 4.0 from 3.0 ((tdnf error code: 21).

Error: Packages - <pkg_name1(s)> - are not available in the target repo for OS upgrade. Please provide the correct repo having the required packages.

Original list of RPMs and RPM DB are stored in /tmp/photon-upgrade.sh-XXXX-XX-XX-XX-XX-XX,  please provide contents of that folder along with system journal logs for analysis; these logs can be captured using command-
# /usr/bin/journalctl -xa > /tmp/photon-upgrade.sh-XXXX-XX-XX-XX-XX-XX/journal.log
Cannot continue. Aborting.

 

Environment

VCF 4.X, 5.X

Cause

The failure is caused by RPMs on the current SDDC Manager being incompatible with those required for the upgrade to version 5.2. Since these RPMs are not included in the target version repository, it errors out.

The presence of RPMs mentioned in log snippets might be left behind by previous upgrades or greenfield deployments, or if a user had implicitly or explicitly installed those RPMs.

 

Resolution

To resolve this issue, follow these steps to remove all the conflicting packages individually:

  • Confirm Package Existence :

    rpm -qa | grep -i <pkg_name1>

  • Take a Snapshot of SDDC Manager :

    Ensure that you have taken a snapshot of the current state of the SDDC Manager and that backups are available.

  • Remove  conflicting RPM via CLI : Use tdnf to remove the incompatible package:

    tdnf remove <pkg_name1> -y

If this command fails, use the following workaround:

rpm -e <pkg_name1>

In some cases some packages have dependencies and therefore , we need to remove both

rpm -e <pkg_name1> <pkg_name2>

You might see multiple re-attempts and errors followed by the removal confirmation:

Removing:
<pkg_name1>                                    x86_64                 1.4.4-1.ph3                    @System                 490.35k 502121
Total installed size: 490.35k 502121
Testing transaction
Running transaction
Removing: <pkg_name1>
Complete!

  • Retry Upgrade :

    After removing the conflicting package(s), retry the upgrade process.

If the above steps do not resolve the issue, please collect the following and contact Broadcom support:

  • A fresh SoS bundle from the SDDC Manager
  • List of the installed RPMs as found by running below command on SDDC-Manager: "rpm -qa"