Error: "Could not handle response content-type text" when attempting to delete or edit a VM in VMware Cloud Director
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Error: "Could not handle response content-type text" when attempting to delete or edit a VM in VMware Cloud Director

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Article ID: 374968

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Updated On:

Products

VMware Cloud Director

Issue/Introduction

  • While trying to edit a VM from VMware Cloud Director(VCD) UI, you might encounter an error: "Could not handle response content-type: text/plain".

  • While trying to delete a VM from VMware Cloud Director UI, you might encounter an error:

    "Could not handle response content-type text/html; charset=utf-8" .

  • Issue occurs when accessing the VCD UI externally as this is behind a firewall.
  • Accessing VCD UI directly (bypassing the firewall), you are able to edit and save the configuration changes on the VM.
  • When inspecting VCD API responses you observe a message from a Network firewall or Web Application Firewall (WAF) in front of VCD which states:

    The requested URL was rejected. Please consult with your administrator.
    Your support ID is: #####

Environment

VMware Cloud Director 10.6.x
VMware Cloud Director 10.5.x

Cause

This issue can occur due to environmental network configuration factors including but not limited to:

  • Network firewall or Web Application Firewall (WAF) configuration issue.
  • Network connectivity Issues.
  • Loadbalancer configuration issue.
  • A browser specific issue which can occur when the Client Browser has issues sending and receiving API calls to/from VMware Cloud Director.
  •  

Resolution

To resolve this issue inspect the environment for network connectivity or configurations issues such as the following:

  1. Ensure the network firewall or WAF is not blocking 'content-type: text/html' or 'content-type: text/plain'  headers.
  2. Any connectivity issue which would result in the Client machine losing connectivity to the Cloud Director Cells/Load Balancer would result in the error.
  3. Instances which have been observed to cause the issue would be
    1. VPN Disconnection or Re-authentication
    2. Machine NIC disconnection
  4. Check for Load Balancer configuration issues.

If matters persist then engage with your local networking/security team for their review.