Upgrade status summary API reported incorrect status for upgrade post complete upgrade was done
search cancel

Upgrade status summary API reported incorrect status for upgrade post complete upgrade was done

book

Article ID: 374906

calendar_today

Updated On:

Products

VMware NSX

Issue/Introduction

The following API is used to retrieve the upgrade status:
GET /upgrade-coordinator/api/v1/upgrade/status-summary

When checking [System] > [Upgrade] in NSX Manager UI, The upgrade status of NSX Manager may sometimes regress, making it appear as if the upgrade is still in progress even though the upgrade has been completed.

Also, the progress may regress based on the results of the API execution, causing the overall upgrade status to become "PAUSED."

GET /upgrade-coordinator/api/v1/upgrade/status-summary
  {
    "component_status": [
      {
        "can_rollback": false,
        "can_skip": false,
        "component_type": "MP",
        "current_version_node_summary": {
          "results": [
            {
              "component_version": "Done",
              "node_count": xxx,
              "type": "MP",
              "upgrade_unit_subtype": "ACTION"
            },
            {
              "component_version": "Pending",
              "node_count": xxx,
              "type": "MP",
              "upgrade_unit_subtype": "ACTION"
            }
          ]
        },
        "node_count_at_target_version": xxx,
        "percent_complete": 81.0, <---!
        "pre_upgrade_status": {
          "end_time": xxx,
          "error_count": 0,
          "failure_count": 1,
          "start_time": xxx,
          "status": "COMPLETED",
          "warning_count": 1
        },
        "status": "FAILED", <---!
        "target_component_version": "xxx"
      }
    ],
    "overall_upgrade_status": "PAUSED" <---!
  },

Environment

VMware NSX 4.0
VMware NSX 4.1

Cause

When upgrade is successfully completed, each NSX Manager node performs sync plan and calculate progress again.
If one of NSX Manager nodes was down when the upgrade was completed, the Manager node becomes out-of-sync and its upgrade status shows regressed status.

Resolution

Workaround

Log in to the GUI of all NSX Managers and display the Upgrade UI so that the Upgrade Coordinator syncs the plan and status.
Do following steps on all NSX Managers:

1. Login to NSX Manager GUI.
2. Navigate to [System] > [Upgrade]