Client fails to estabslish persistent connection
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Client fails to estabslish persistent connection

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Article ID: 374842

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Updated On:

Products

Client Management Suite

Issue/Introduction

Despite the configured persistent connection clients fail to connect to server (SMP or Task Server) and fall back to HTTP(S)

Environment

ITMS 8.x

Cause

One of the reasons is server is not listening to websockets:

  • WebSocket protocol is removed from roles/features
  • WebSocket service state is not enabled.
    Check status with
    netsh http show servicestate

    or pipe out to
    netsh http show servicestate > c:\netsh.txt
Server session ID: FA0000012000209C
    Version: 2.0
    State: Active
    Properties:
        Max bandwidth: 4294967295
        Timeouts:
            Entity body timeout (secs): 120
            Drain entity body timeout (secs): 120
            Request queue timeout (secs): 120
            Idle connection timeout (secs): 120
            Header wait timeout (secs): 120
            Minimum send rate (bytes/sec): 150
    URL groups:
    URL group ID: FB00000140001628
        State: Active
        Request queue name: Request queue is unnamed.
        Properties:
            Max bandwidth: inherited
            Max connections: inherited
            Timeouts:
                Timeout values inherited
            Number of registered URLs: 1
            Registered URLs:
                HTTPS://+:4726/ALTIRIS/WEBSOCKETS/

If //..WEBSOCKETS/ cannot be found server will not accept any persistent connections from clients.

Resolution

Missing Websocket Roles and features can be re-introduced/enabled.

Attempt to address missing HTTP service with a restart.