Intermittent failure on Aria Orchestrator action with  singleton object VraEntitiesFinder
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Intermittent failure on Aria Orchestrator action with  singleton object VraEntitiesFinder

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Article ID: 374827

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

  • Running a Aria Orchestrator action which has the singleton object "VraEntitiesFinder" to get Aria Automation objects is failing intermittently.

    "Error occured due to empty response with error code: 401 (dynamic script module name : getCloudZoneTagsByName#3"



  • You will see Could not delegate token error in the  vco-server-app.log file

         ERROR vco [host='vco-app-<UUID>' thread='http-<ID>' user='<username>' org='<org-id>' trace='-'] {} com.vmware.o11n.security.csp.CspTokenDelegationService - Could not delegate token.
         org.springframework.web.client.HttpClientErrorException$NotFound: 404 Not Found: "{"timestamp":1718623743738,"type":"CLIENT_ERROR","status":"404 NOT_FOUND","error":"Not Found","serverMessage":"404 NOT_FOUND \"New access and refresh tokens cannot be obtained with the provided           subject_token.\""}"
         at org.springframework.web.client.HttpClientErrorException.create(HttpClientErrorException.java:113) ~[spring-web-5.3.32.jar:5.3.32]
         at org.springframework.web.client.DefaultResponseErrorHandler.handleError(DefaultResponseErrorHandler.java:168) ~[spring-web-5.3.32.jar:5.3.32]
         at org.springframework.web.client.DefaultResponseErrorHandler.handleError(DefaultResponseErrorHandler.java:122) ~[spring-web-5.3.32.jar:5.3.32]
         at org.springframework.web.client.ResponseErrorHandler.handleError(ResponseErrorHandler.java:63) ~[spring-web-5.3.32.jar:5.3.32]

                  

                 

 

Environment

VMware Aria Automation 8.16.x

VMware Aria Automation 8.18.1

 

 

Cause

Issue identified as related to the caching of internal factories and key collisions, coupled with the heavy use of basic authentication in this particular environments.

 

Resolution

Please contact Broadcom's technical support team and refer to this knowledge base article to help resolve the issue.