Lifecycle Manager tab is empty in vSphere Client
search cancel

Lifecycle Manager tab is empty in vSphere Client

book

Article ID: 374800

calendar_today

Updated On:

Products

VMware vCenter Server

Issue/Introduction

Navigating to the Lifecycle Manager tab shows no data in vSphere Client and the vmware-updatemgr service is stopped and will not start.

Attempts to start the vmware-updatemgr service fails immediately the vmware-vum-server log shows SSL errors while trying to refresh certificates:

/var/log/vmwarevmware-updatemgr/vum-server/vmware-vum-server.log 

<timestamp> info vmware-vum-server[14008] [Originator@6876 sub=IO.Http] Set user agent error; state: 3, SSL(<io_obj p:0x00007fc8c8cbf8b8, h:20, <TCP '127.0.0.1 : 42586'>, <TCP '127.0.0.1 : 80'>>), N7Vmacore4Http24MalformedHeaderExceptionE(Server closed connection after 0 response bytes read)
--> [context]zKq7AVECAQAAAHI5KQEPdm13YXJlLXZ1bS1zZXJ2ZXIAAB7oN2xpYnZtYWNvcmUuc28AAAGJLACJey0Ahu8yAKC2MACuuTAAuvgwAM40LQBEFSMAkLkjAJdaIwA/sCMA3HM3AYd/AGxpYnB0aHJlYWQuc28uMAAC7zUPbGliYy5zby42AA==[/context]
<timestamp> error vmware-vum-server[14008] [Originator@6876 sub=IO.Http] User agent failed to send request; SSL(<io_obj p:0x00007fc8c8cbf8b8, h:-1, <TCP '127.0.0.1 : 42586'>, <TCP '127.0.0.1 : 80'>>), N7Vmacore4Http24MalformedHeaderExceptionE(Server closed connection after 0 response bytes read)
--> [context]zKq7AVECAQAAAHI5KQEPdm13YXJlLXZ1bS1zZXJ2ZXIAAB7oN2xpYnZtYWNvcmUuc28AAAGJLACJey0Ahu8yAKC2MACuuTAAuvgwAM40LQBEFSMAkLkjAJdaIwA/sCMA3HM3AYd/AGxpYnB0aHJlYWQuc28uMAAC7zUPbGliYy5zby42AA==[/context]
<timestamp> warning vmware-vum-server[31751] [Originator@6876 sub=InventoryMonitor] [InventoryMonitor 1786] WaitForUpdatesEx failed. Will retry, retries remaining: 9 Error: Server closed connection after 0 response bytes read
<timestamp> info vmware-vum-server[28812] [Originator@6876 sub=managedJetty] [managedJetty 457] Jetty: Update manager stopping

 

/var/log/vmware/vmware-updatemgr/refreshCerts-utility.log indicates that the vci-integrity.xml file is not readable:

[<timestamp> ERROR] Unable to parse vci-integrity.xml: mismatched tag: line 83, column 4
[<timestamp> INFO] Creating/Updating key file: /usr/lib/vmware-updatemgr/bin/ssl/rui.key
[<timestamp> INFO] Creating/Updating certificate file: /usr/lib/vmware-updatemgr/bin/ssl/rui.crt
[<timestamp> INFO] Creating/Updating key file: /usr/lib/vmware-updatemgr/bin/ssl/jetty.key
[<timestamp> INFO] Creating/Updating certificate file: /usr/lib/vmware-updatemgr/bin/ssl/jetty.crt
[<timestamp> INFO] Install Key store for Jetty
[<timestamp> INFO] Keystore installed successfully.
[<timestamp> INFO] Enter registerWithVcNoRestart
[<timestamp> ERROR] Unable to parse vci-integrity.xml: mismatched tag: line 83, column 4

 

Environment

vCenter Server

Cause

Incorrect xml formatting in the file /etc/vmware/service-state/updatemgr/vci-integrity.xml

Resolution

Validate the /etc/vmware/service-state/updatemgr/vci-integrity.xml file around the line number highlighted in the log file, for example line 83, column 4. 

1. For example, adding the lesser than symbol (<)  to correct the xml tag ie. <VMEvacuationTimeout>7200/VMEvacuationTimeout> to <VMEvacuationTimeout>7200</VMEvacuationTimeout>
2. Restart the vmware-updatemgr service using the command "service-control --start vmware-updatemgr"