Changing node hostname on Management -> Cluster page in Aria Operations for logs
search cancel

Changing node hostname on Management -> Cluster page in Aria Operations for logs

book

Article ID: 374773

calendar_today

Updated On:

Products

VMware Aria Suite

Issue/Introduction

After adding new worker node to Aria Operations for logs cluster. The node comes up with IP address in the cluster management page instead of the FQDN.

 

Environment

Aria Operations for logs 8.x

Cause

DNS record was created after the node was deployed and added to the cluster.

Resolution

  1. SSH to the Primary node via root account and navigate to config directory.
    cd /storage/core/loginsight/config

     

  2. Open the config file with the highest number. Replace XX everywhere with the highest number seen after first command below.
    ls -l
    cat loginsight-config.xml#<xx>

     

  3. Backup the file.
    cp loginsight-config.xml#<xx>  loginsight-config.xml#<xx>.backup

     

  4. Open the file and change the daemon host='IP' field to FQDN which shows IP address currently.
    vi loginsight-config.xml#<xx>

     

  5. Save and close the file. 


  6. Restart log-insight service.
    service loginsight restart
     

Additional Information

If the operation is successful delete the .backup file we created in step 3 above.