"Duplicate entries in SplitDNS config discovered for 'example.com'" warning on WSS Agent logs
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"Duplicate entries in SplitDNS config discovered for 'example.com'" warning on WSS Agent logs

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Article ID: 374767

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Updated On:

Products

Cloud Secure Web Gateway - Cloud SWG Symantec ZTNA

Issue/Introduction

WSS Agent setup using Agent Traffic Manager to forward all traffic into Cloud SWG.

ZTNA integrate with Cloud SWG, where a DNS server settings is enabled on the ZTNA 'WSS' Configuration side.

When any user that matches the ZTNA interception rule connects with WSS Agent, the logs report the following warning:

Duplicate entries in SplitDNS config discovered for 'example.com'

Users appear to be able to access all internet sites and segment applications configured, so warning appears to be cosmetic.

Environment

ZTNA.

Segment Applications.

Cloud SWG.

Cause

CTC sending back duplicate information to WSS Agent.

Resolution

Reset the ZTNA DNS configuration using the following steps:

  • Go into ZTNA -> Settings -> DNS servers
  • Remove the DNS config completely
  • Reconnect with WSS Agent (make sure warning has gone)
  • Add DNS config again

Additional Information

For some reason, the CTC information being sent back to the host included duplicate information for the ZTNA DNS setup as shown below. By resetting the DNS configuration on the ZTNA side, one cleared the previouly stored information and forced an update which addressed the issue.

  "splitDNS": [
    {
      "host": "example.com",
      "ip": "192.168.11.6"
    },
    {
      "host": "example.com",
      "ip": "192.168.11.6"
    }
  ],