Error: "Results may be inaccurate because not all nodes successfully returned results" in Aria Operations for Logs
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Error: "Results may be inaccurate because not all nodes successfully returned results" in Aria Operations for Logs

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Article ID: 374640

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

Symptom 1

  • When you log in to Aria Operations for Logs and navigate to Dashboards > Content Pack Dashboards > VMware vSphere > General - Problems Dashboard, a warning may be displayed. Upon clicking the warning symbol, the error message "Results may be inaccurate because not all nodes successfully returned results" appears, as shown in the screenshot below

 

Symptom 2

  • The message "Results may be inaccurate because not all nodes successfully returned results" also appears if there are corrupted hint files in any node(s). This can be verified from the cassandra.log file in /storage/core/loginsight/var/ location of the affected node. Use nodetool-no-pass status command to check which node is affected. The affected node will be in 'DN' state as shown below:

  • Below errors would be seen in /storage/core/loginsight/var/cassandra.log file:
    • ERROR [HintsDispatcher:1] 2025-01-14T07:22:10,223 HintsDispatchExecutor.java:260 - Failed to dispatch hints file xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx-xxxxxxxxxxxxx-2.hints: file is corrupted org.apache.cassandra.io.FSReadError: java.io.IOException: Corrupt hint file found
    • ERROR [HintsDispatcher:1] 2025-01-14T07:33:02,828 JVMStabilityInspector.java:68 - Exception in thread Thread[HintsDispatcher:1,1,HintsDispatcher] org.apache.cassandra.io.FSReadError: java.io.IOException: Corrupt hint file found

Environment

  • Aria Operations for Logs 8.x

Cause

Cause 1

  • This issue typically arises when there is an error (e.g., "vSphere Configuration setup failed") or a warning (e.g., "vCenter Server SSL Certificate is not trusted") under the VC Collections Status in the vSphere integration page




 

Cause 2

  • The Cassandra 'hints' file, which resides under "/usr/lib/log insight/application/lib/apache-cassandra-*/data/hints," is corrupted. 

Resolution

Symptom 1

Follow the below steps to resolve this:

  1. Log in to Aria Operations for Logs using the FQDN or IP Address
  2. Expand the main menu and go to Integration > vSphere
  3. In the vCenter Server table, find the vCenter Server instance showing the Error or Warning, and click Edit.
  4. Enter the service account credentials for the vCenter Server, then click Test Connection
  5. If the vSphere environment presents an untrusted SSL certificate, a dialog box will appear with the certificate details. Click Accept to add the certificate to the truststores of all nodes in the VMware Aria Operations for Logs cluster.
  6. Click Save, then wait a few minutes and refresh the page.
  7. Verify that the VC Collection status now shows as "Collecting." The warning will automatically clear from the Dashboards > Content Pack Dashboards > VMware vSphere > General - Problems Dashboard.

 

Symptom 2